Several services are temporarily unavailable
Incident Report for Huobi
Resolved
This incident has been resolved.
Posted Mar 30, 2020 - 05:50 UTC
Investigating
We are currently investigating this issue.
Posted Mar 30, 2020 - 05:42 UTC
This incident affected: Spot & Margin Trading (Order Place, Order Cancel) and Authentication, Asset Transfer.